程序设计与算法二郭炜递归005Boolean Expressions及解题思路

题目

The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next:
Expression: ( V | V ) & F & ( F | V )

where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed.

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file.

输入

The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown.

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below.

输出

For each test expression, print "Expression " followed by its sequence number, ": ", and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line.

Use the same format as that shown in the sample output shown below.

样例输入

( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))

样例输出

Expression 1: F
Expression 2: V
Expression 3: V

解题思路

使用函数嵌套函数的递归, | 优先级最低再最外层,然后是 & 运算,再是返回元素(V和F),最后如果前面有 !,要优先算 !。

代码实现

我的解法

# include <iostream>
# include <cstring> 
using namespace std;

char expression_value(char exp[]);
// 计算 ! 的一层
char not_value(char exp[])
{
	char op,value;
	while(*exp == ' ' || *exp == '0'){
	    if(*exp == ' ') *exp = '0';
		exp++;
	}
	op = *exp;
	if(op == '!'){
		*exp = '0';
		exp++;
		value = not_value(exp);
		if(value == 'V') value = 'F';
		else value = 'V';
	}
	else if(op == '('){
		*exp = '0';
		exp++;
		value = expression_value(exp);
		if(value == 'V') value = 'F';
		else value = 'V';
	}
	else{
		*exp = '0';
	    value = op;
	    if(value == 'V') value = 'F';
	    else value = 'V';	
	}

	return value;
}
// 返回 元素 的一层
char factor_value(char exp[])
{
	char op,value;
	while(*exp == ' ' || *exp == '0'){
		if(*exp == ' ') *exp = '0';
		exp++;
	}
	op = *exp;
	if(op == '('){
		*exp = '0';
		exp++;
		value = expression_value(exp);
	}
	else if(op == '!'){
		*exp = '0';
		exp++;
		value = not_value(exp); 
	}
	else{
		value = op;
		*exp = '0';
	}
	
	return value;
}
// 计算 & 一层
char term_value(char exp[])
{
	char result = factor_value(exp);
	char op;
	while(*exp == ' ' || *exp == '0'){
		if(*exp == ' ') *exp = '0';
		exp++;
	}
	op = *exp;
	while(1){
		if(op == '&'){
			*exp = '0';
			exp++;
			char value = factor_value(exp);
			if(result == 'V' && value == 'V') result = 'V';
			else result = 'F';
	        while(*exp == ' ' || *exp == '0'){
		        if(*exp == ' ') *exp = '0';
		        exp++;
	        }
	        op = *exp;
		}
		else break;
	}
	
	return result;
}
// 计算 | 的一层
char expression_value(char exp[])
{
	char result = term_value(exp);
	char op; //  所有op都是存储当前运算符
	while(*exp == ' ' || *exp == '0'){
		if(*exp == ' ') *exp = '0';
		exp++;
	}
	op = *exp;
	while(1){
		if(op == '|'){
			*exp = '0';
			exp++;
			char value = term_value(exp);
			if(result == 'F' && value == 'F') result = 'F';
			else result = 'V';
			while(*exp == ' ' || *exp == '0'){
		        if(*exp == ' ') *exp = '0';
		        exp++;
	        }
	        op = *exp;
		}
		else{
			*exp = '0';
			break;
		} 
	}
	
	return result;
}

int main()
{
	char s[101] = {0};
	int cnt = 1;
	char *exp;
	
	while(gets(s)){
		exp = s;
		cout << "Expression "<< cnt << ": " << expression_value(exp) <<endl;
		memset(s,0,sizeof(s));
		cnt++;
	}
	
	return 0;
	 
}

参考代码

#include <iostream>
#include <cstdio>
using namespace std;
char wholeExp[200];
bool exp();
bool factor();
bool item();
int ptr = 0;
bool exp() {
	bool result = item();
	while(wholeExp[ptr] == '|' ) {
		++ptr;
		result = result | item();
	}
	return result;
}
bool item() {
	bool result = factor();
	while(wholeExp[ptr] == '&') {
		++ptr;
		result = result & factor();
	}
	return result;
}
bool notExp()
{
	//wholeExp[ptr] == '!' when called;
	ptr++;
	bool result;
	switch(wholeExp[ptr]) {
		case 'F':
			++ptr;
			return true;
			break;
		case 'V':
			++ptr;
			return false;
			break;
		case '(':
			++ptr;
			result = exp();
			++ptr;  //skip ')'
			return !result;
			break;
		case '!':
			result = notExp();
			return !result;
			break;
	}
}

bool factor() {
	bool result;
	switch( wholeExp[ptr]) {
		case 'F':
			++ptr;
			return false;
			break;
		case 'V':
			++ptr;
			return true;
			break;
		case '(': 
			++ptr;
			result = exp();
			++ptr;
			return result;
			break;
		case '!':
			result = notExp();
			return result;
			break;
	}
}


int main()
{
	char c;
	int i = 0;
	int t = 1;
	int n = EOF + 1; 
	while(n != EOF) {
		 n =  scanf("%c",&c);
		if(	n == EOF || c == '\n') {
			wholeExp[i] = 0;
			if( i > 0) {
				ptr = 0;
				bool r = exp();
				if (r) {
					printf("Expression %d: V\n",t++);
				}
				else 
					printf("Expression %d: F\n",t++);
			}
			i = 0;
		}
		else if( c != ' ') 
			wholeExp[i++] = c;
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值