1002 A+B for Polynomials

This time, you are supposed to find A+BA+BA+B where AAA and BBB are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

KKK N1N_1N​1​​ aN1a_{N_1}a​N​1​​​​ N2N_2N​2​​ aN2a_{N_2}a​N​2​​​​ ... NKN_KN​K​​ aNKa_{N_K}a​N​K​​​​

where KKK is the number of nonzero terms in the polynomial, NiN_iN​i​​ and aNia_{N_i}a​N​i​​​​ (i=1,2,⋯,Ki=1, 2, \cdots , Ki=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤101 \le K \le 101≤K≤10,0≤NK<⋯<N2<N1≤10000 \le N_K < \cdots < N_2 < N_1 \le 10000≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of AAA and BBB in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

注意事项:

(1)输出需要保留小数点后一位

(2)结尾不能留空格

(3)系数为0时不输出

 

代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	float a[2][1001];
	memset(a, 0, sizeof(a));
	int K,N,max=0;
	for (int i = 0; i < 2; i++)
	{
		cin >> K;
		while (K--)
		{
			cin >> N;
			cin >> a[i][N];
			max = max > N ? max : N;//找出最大的指数			
		}
	}

	int sum = 0,n[1001],min=1001;
	memset(n, -1, sizeof(n));
	for (int j = 0; j <= max; j++)
	{
		a[0][j] = a[0][j] + a[1][j];
		if (a[0][j] != 0)//找出系数存在的项
		{
			sum++;
			n[j] = j;
			min = min < j ? min : j;
		}
	}
	cout << sum;
	if (sum != 0)//如果没有系数那么sum后面不需要空格
	{
		cout << " ";
		for (int k = max; k >= min; k--)
		{
			if (n[k] != -1)
			{
				printf("%d %.1f", k, a[0][k]);
				if (k!=min)cout << " ";
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值