1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

注意事项: 

(1)结尾没有空格

(2)输出每一代的没孩子的人的个数

解题思路:

(1)可以用Map数组来存放每个人的父母

(2)将根节点的那一代父母都设定为0,即mp[x]=0

(3)用vector数组存放每一个人的所有孩子,Num数组存放每一代没有孩子的人的个数

(4)用递归来找出每一代没有孩子的人的个数

(5)首先找出第一代的所有人,即mp[x]=0,通过判断vector数组是否为空来找出没孩子的人的个数,将有孩子的人进行递归,找他们下一代没有孩子的人的个数。

(6)找到的人数都存放在Num数组中,在程序最后输出。

代码如下:

#include<bits/stdc++.h>
using namespace std;
int Num[101] = { 0 }, Max = 0;
vector<int>st[100];
void FindNoChild(int t,int generation)// t为这个人的编号,generation为第几代
{
	Max = Max > generation ? Max : generation;
	if (st[t].empty())        //统计没有孩子的人的个数
		Num[generation]++;
	else
	{
		for (int i = 0; i < st[t].size(); i++)
			FindNoChild(st[t][i], generation + 1);//将有孩子的人的孩子进行递归
	}
}
int main()
{
	map<int, int>mp;
	int N, M;
	cin >> N >> M;
	for (int i = 1; i <= N; i++)
		mp[i] = 0;

	for (int j = 0; j < M; j++)
	{
		int ID, K;
		cin >> ID >> K;

		for (int k = 0; k < K; k++)
		{
			int id;
			cin >> id;
			st[ID].push_back(id); //存放所有的孩子
			mp[id] = ID; //设定他们的父母
		}
	}

	for (int p = 1; p <= N; p++)
	{
		if (mp[p] == 0)    //找出第一代
		{
			if (st[p].empty())
				Num[0]++;
			else
			{
				for(int q=0;q<st[p].size();q++)
					FindNoChild(st[p][q], 1);
			}
		}
	}

	for (int u = 0; u < Max; u++)
		cout << Num[u] << " ";
	cout << Num[Max];            //结尾没空格
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值