1004. Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1  

算法:

  1. 算法开始。
  2. 定义结构体node,包含int类型的指针child,int类型的k。
  3. 读入N和M。设置大小为N+1类型为node的数组family,把每个元素的ID设置为0,child设置为NULL,k=0。
  4. i=0。
  5. 如果i小于M,继续,否则跳到第十三步。
  6. 读入ID和k。
  7. family[ID].child = (int*)calloc(k+1, sizeof(int)),family[ID].k = k。
  8. j=1。
  9. 如果j小于等于k,则继续,否则进行第十二步。
  10. 读入ID[j],赋值给family[ID].child[j]。
  11. j加一,返回第九步。
  12. i加一,返回第五步。
  13. 设ID01的辈分为0,设置int类型的数组leaf_count,大小为N,每个元素初始化为0。
  14. 设置变量g=0,i为1。
  15. 对family[i]进行判断,如果k==0,则leaf_count[g]++。
  16. 对g加一,然后对family[i]的每一个孩子进行第十五步。
  17. i = 0。
  18. 如果i小于g,则进行第十九步,否则进行第二十一步。
  19. 输出g代的无孩子的人的人数。
  20. i++,返回第十八步。
  21. 算法结束。

#include <stdio.h>
#include <stdlib.h>
typedef struct node{
    int* child;
    int k;
} node;

void traversal(node* family, int id, int g);

int* leaf_count;
int max_g = 0;

int main(int argc, const char * argv[]) {
    int n, m, k, i, j, id, id_j;
    node* family;
    scanf("%d %d", &n, &m);
    
    family = (node*)calloc(n + 1, sizeof(node));
    leaf_count = (int*)calloc(n, sizeof(int));
    
    for(i = 0; i < m; i++){
        scanf("%d %d", &id, &k);
        family[id].k = k;
        family[id].child = (int*)calloc(k, sizeof(int));
        for(j = 0; j < k; j++){
            scanf("%d", &id_j);
            family[id].child[j] = id_j;
        }
    }
    traversal(family, 1, 0);
    for(i = 0; i < max_g; i++){
        printf("%d ", leaf_count[i]);
    }
    printf("%d\n", leaf_count[i]);
    free(leaf_count);
    for(i = 0; i < n; i++){
        if(family[i].child != NULL){
            free(family[i].child);
        }
    }
    free(family);
    return 0;
}

void traversal(node* family, int id, int g){
    int i;
    if(g > max_g){
        max_g = g;
    }
    if(family[id].child == NULL){
        leaf_count[g]++;
    }
    for(i = 0; i < family[id].k; i++){
        traversal(family, family[id].child[i], g + 1);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值