1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

解题思路:说来惭愧,这道题没用二分写的时候总是超时,后来参照了某位博主的答案之后豁然开朗,在此附上连接: https://blog.csdn.net/CV_Jason/article/details/80993283

代码如下:

#include<bits/stdc++.h>
using namespace std;
long long Trans(string str, int radix) {
	long long sum = 0;
	int index = 0;
	int per_digit = 0;
	for (int i = str.length() - 1; i >= 0; i--) {
		per_digit = isdigit(str[i]) ? str[i] - '0' : str[i] - 'a' + 10;
		sum += per_digit * pow(radix, index++);
	}
	return sum;
}

long long Find_radix(string str, long long num) {
	long long result_radix = -1;
	char it = *max_element(str.begin(), str.end());
	long long low = (isdigit(it) ? it - '0' : it - 'a' + 10) + 1;
	long long high = max(low, num);

	while (low <= high) {
		long long mid = (low + high) / 2;
		long long temp = Trans(str, mid);

		if (temp<0 || temp>num) {
			high = mid - 1;
		}
		else if (temp < num) {
			low = mid + 1;
		}
		else {
			result_radix = mid;
			break;
		}
	}
	return result_radix;

}

int main() {
	string N1;
	string N2;
	int tag;
	long long radix;
	cin >> N1 >> N2 >> tag >> radix;

	long long known_num = (tag == 1 ? Trans(N1, radix) : Trans(N2, radix));

	long long result = Find_radix((tag == 1 ? N2 : N1), known_num);

	if (result != -1) {
		cout << result << endl;
	}
	else {
		cout << "Impossible" << endl;
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值