西安工业大学是国家二级保密单位,常常接到一些军方保密项目。但是保密的项目要求很严格。1.不能使用自己的计算机,需要使用特配的。2.计算机不能接入互联网。3.代码的合并以及转移不能通过U盘,只能通过特定的光盘。4.代码的格式也有严格要求。
以下为某次保密项目部分代码要求:
小明完成了任务,但不知道自己的代码是否符合规范。你只需要帮他在这里判断重名最多的变量名称和它重复的次数。
输入格式:
第一行给出一个整数N(1<=n<=10),接下来N行,每行给出一行字符串S(长度<100)。所有样例保证出现最多的变量名称唯一,且程序语句无错误(类型名称 变量名称 = 值)。但是在语句正确的情况下不保证无多余空格。每一行仅包含一个语句。定义不包含const等修饰符。
标红的话仔细品!!!
输出格式:
程序结束后你需要输出重名最多的变量名称和它重复了多少次。
输入样例:
5
int a = 2;
int b = 3;
double k = 5.625;
char a = 'a';
float a = 1.567;
输出样例:
a 3
tips:变量名为每一行第二个单词
上方这个tips是个重要的信息
我们可以只记住第二个字符串,将其视为变量名
所以上普通解法代码:
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<sstream>
#include<fstream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<climits>
#include<algorithm>
#include<cmath>
#include<string>
#include<map>
#include<vector>
#include<stack>
#include<set>
#include<bitset>
#include<cctype>
#include<list>
#include<queue>
using namespace std;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
string str1, str2, str3;
string str[30];
int n, i, j;
cin >> n;
for (i = 0; i < n; i++) {
cin >> str1 >> str2;
getline(cin, str3);//输入完变量名,后面的都可以丢掉,直接一行输入
str[i] = str2;//存住每一次的变量名
}
int a[40];
//下面直接暴力求
for (i = 0; i < n; i++) {
a[i] = 0;
for (j = 0; j < n; j++) {
if (str[i] == str[j]) {
a[i]++;
}
}
}
int k = 0;
for (i = 0; i < n; i++) {
if (a[k] < a[i]) {
k = i;
}
}
cout << str[k] << " " << a[k];
return 0;
}
但其实我看到这题第一想法就是map
但是我发现map不能计数,于是我使用了multimap,就是可以存重复的键值。然后直接附上代码吧哈哈哈哈本人不太会表达,还仍是个蒻蓟。
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<sstream>
#include<fstream>
#include<algorithm>
#include<cmath>
#include<string>
#include<map>
using namespace std;
string str1, str2, str3, str4, str;
multimap<string, int>ma;
int n, a[100101], cnt, ans, m;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
cin >> n;
while (n--) {
cin >> str1 >> str2;
getline(cin, str3);
ma.insert(multimap<string, int>::value_type(str2, cnt++));
if (ans < ma.count(str2)) {
ans = max(ans, (int)ma.count(str2));
str = str2;
}
}
cout << str << " " << ans;
return 0;
}