hiveshell不能执行select语句问题

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/TXBSW/article/details/78872942

最近碰到一个很玄学的问题,就是我的CDH集群中部署的hive,在hue上可以执行hive查询语句,但是到hiveshell中不能执行!废话不多说直接看报错图吧
报错信息
猛的一看以为缺啥jar包,但是想想不应该啊,我用cludera CDH部署的,然后带着这个问题去问度娘,度娘告诉我说不hive版本与hadoop版本不一致,我当时是崩溃的,不应该啊,我cdh、
部署不存在这个问题的。然后各种求教大神,然而并没有什么帮助。今天突然心血来潮,启动hive,看着一串报警不爽,就按照度娘给的方案,删除冲突jar包具体请看图
没删jar之前hive启动状况
然后到/opt/cloudera/parcels/CDH-5.12.1-1.cdh5.12.1.p0.3/lib/hbase/lib/目录下面删掉了phoenix-4.13.0-HBase-1.3-client.jar
之后启动hive
删jar之后启动状态
随后执行一下select语句
成功了!!!
看到没?成功了。一开始我以为那些报警信息无关紧要,只要不是报错就没管他们。然而罪魁祸首就是他们。结合度娘与自己经验总结一下,凡是报这个错误信息的,必然是jar包冲突导致的。所以自己要细心查找,未必会是hive与hadoop版本不一致,有时候会有其他冲突。
问题解决了!大数据就是从入门到放弃,一步一坑的自己爬过来。

展开阅读全文

没有更多推荐了,返回首页