CCPC 2015 A题

Secrete Master Plan

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)

Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately,when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form a 2×2 matrix, but Fei didn't know the correctdirection to hold the sheet. What a pity!

Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might giveFei the wrong pocket. Determine if Fei receives the right pocket.

title

Input

The first line of the input gives the number of test cases, T ( 1T104 ). T test cases follow. Each test case contains 4 lines. Each line contains two integers ai0 and ai1 ( 1ai0,ai1100 ). The first two lines stands for the original plan, the 3rd and 4th line stands for the plan Fei opened.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1 ) and y is either "POSSIBLE" or "IMPOSSIBLE"(quotes for clarity).

Sample input and output

Sample InputSample Output
4
1 2
3 4
1 2
3 4

1 2
3 4
3 1
4 2

1 2
3 4
3 2
4 1

1 2
3 4
4 3
2 1
Case #1: POSSIBLE
Case #2: POSSIBLE
Case #3: IMPOSSIBLE
Case #4: POSSIBLE

Source

The 2015 China Collegiate Programming Contest


题目大意:给你两个2*2矩阵的矩阵,问第一个矩阵是否通过旋转的到第二个矩阵;
水题,直接贴代码;

# include <stdio.h>
# include <math.h>
#include<string.h>
#include<algorithm>
using namespace std;

void zhuanhuan(int a[2][2])
{
    int t=a[0][0];
    a[0][0] = a[1][0];
    a[1][0] = a[1][1];
    a[1][1] = a[0][1];
    a[0][1] = t;
}

bool judge(int a[2][2],int mark[2][2])
{
    for(int i=0; i<2; i++)
        for(int j=0; j<2; j++)
            if(a[i][j]!=mark[i][j])
                return false;
    return true;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int c=1; c<=t; c++)
    {
        int mp[2][2],mark[2][2];
        for(int i=0; i<2; i++)
            for(int j=0; j<2; j++)
                scanf("%d",&mp[i][j]);
        for(int i=0; i<2; i++)
            for(int j=0; j<2; j++)
                scanf("%d",&mark[i][j]);
        bool in = false;
        for(int i=0; i<4; i++)
        {
            if(judge(mp,mark))
            {
                printf("Case #%d: POSSIBLE\n",c);
                in = true;
                break;
            }
            zhuanhuan(mp);
        }
        if(in == false) printf("Case #%d: IMPOSSIBLE\n",c);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值