hdu 1541 Stars

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0

题目大意:给你一个数字n,然后n个有序的坐标,以y轴由小到大,相等情况下x轴由小到大;它左下角(不大于自身x,不大于自身y)星星的数量就是它的星级;问各个星级的数量;

在同一排(也就是y轴相等)的情况下, 当一个x输入, 后面所有星星的星级都要加1;
处理完一排星星后,上面(y轴大的在上面)一排的星星y轴坐标是绝对大于下面一排的, 所以该点的星级等于之前所有不大于该点x轴坐标的数值的和;
典型的树状数组,博主巨弱,看好久都没看出来,,,,
感觉这道题目真的挺好的

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n, a[32005], c[32005];

int sum(int s)
{
    int ans=0;
    while(s>0)
    {
        ans += a[s];
        s -= s&-s;
    }
    return ans;
}
void add(int s, int x)
{
    while(s<=32000)
    {
        a[s] += x;
        s += s&-s;
    }
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        for(int i=1; i<=n; i++)
        {
            int s,t;
            scanf("%d%d",&s,&t);
            c[sum(s+1)]++;
            add(s+1,1);
        }
        for(int i=0; i<n; i++)
            printf("%d\n",c[i]);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值