POJ 3370 Halloween treats——鸽巢原理+思维

【题目描述】
POJ 3370 Halloween treats
Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year’s experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , … , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print “no sweets” instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source
Ulm Local 2007
【题目分析】
我们由鸽巢原理的n种玄学推论中的一个:任意m个数中必定存在一个连续的子串和为m的倍数(我也不会证明)可以知道:因为n>=c,所以一定有答案,而且一定存在一个连续的答案,问题现在就是我们如何在很短的时间内找到这个字串。
暴力时间肯定是不允许的,所以我们必须想其他方法。

自己实在想不出来怎么在 O ( n ) O(n) O(n)时间内找到这个串,在一个大佬的博客中见到了一种很巧妙的做法:标记前缀和模c的余数,一旦余数重复出现说明和增加了c的倍数,直接输出。哇咔咔,这也太强了。ORZ

【AC代码】

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<climits>
#include<queue>
#include<vector>
#include<set>
#include<map>
using namespace std;

typedef long long ll;
const int MAXN=100005;
int sum,t,c;
int a[MAXN];
int vis[MAXN];
int n;
bool flag;

void Print(int l,int r)
{
    for(int i=l;i<r;i++)
    {
        printf("%d ",i);
    }
    printf("%d\n",r);
}

int main()
{
    while(~scanf("%d%d",&c,&n) && (c || n))
    {
        memset(vis,0,sizeof(vis));
        sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=n;i++)
        {
            sum=(sum+a[i])%c;
            if(sum%c==0)
            {
                Print(1,i);
                break;
            }
            else if(vis[sum])
            {
                Print(vis[sum]+1,i);
                break;
            }
            vis[sum]=i;
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值