POJ 3370 Halloween treats - 鸽巢原理

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

鸽巢原理也叫抽屉原理;


【抽屉原理】:原理1 把多于n个的物体放到n个抽屉里,则至少有一个抽屉里的东西不少于两件;

                     原理2 把多于mn(m乘以n)个的物体放到n个抽屉里,则至少有一个抽屉里有不少于m+1的物体。

                     原理3 把无穷多件物体放入n个抽屉,则至少有一个抽屉里 有无穷个物体。.

                     原理 4 把(mn-1)个物体放入n个抽屉中,其中必有一个抽屉中至多有(m—1)个物体。

引用:http://blog.csdn.net/new_wu/article/details/7367025

思路:定理:

         设a1、a2……am是正整数的序列,则至少存在整数k和l,(1<=k<l<=m),使得和a(k+1) + a(k+2) + ... ... +al是m的倍数。

  证明:x%m的余数有(m-1)中可能,即设有(m-1)个鸽巢,设sn代表(a1+a2+...+an)则m个sn产生m个余数,根据鸽巢原理,一定至少有两个s的余数相等,将这连个s想减,中间a(k+1) + a(k+2) + ... ... +al一定是m的倍数。

引用:http://blog.csdn.net/LiWen_7/article/details/8047273


偷懒了,上面引用一下别人博客的东西。

最好的抽屉原理解说,当然是书本:Discrete Mathematics and its Application

根据定理,也就说本题不可能出现没有答案的情况,其中的关键是要求了c <= n,如果没有这个条件,那么本题就无法应用抽屉原理了。

#include <cstdio>
#include <cstdlib>
#include <xutility>

const int MAX_N = 100001;
int arr[MAX_N], modMap[MAX_N];

int main()
{
	int c, n;
	arr[0] = modMap[0] = 0;
	while (scanf("%d %d", &c, &n) != EOF && c)
	{
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", arr+i);
			modMap[i] = -1;
		}
		int lastMod = 0, curMod = 0, l = -1, r = -1;
		for (int i = 1; i <= n; i++)
		{
			curMod = (arr[i] + lastMod) % c;
			if (modMap[curMod] != -1)
			{
				l = modMap[curMod] + 1;
				r = i;
				break;
			}
			modMap[curMod] = i;
			lastMod = curMod;
		}
		if (-1 != l)
		{
			while (l <= r) printf("%d ", l++);
			putchar('\n');
		}
		else puts("no sweets");//可以去掉,因为根据题意,必定有解
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值