PAT甲级1031,1032解题报告

49 篇文章 0 订阅
47 篇文章 0 订阅

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题目大意:给一个字符串,按一定格式输出一下。

解题思路:关键在于确定有几行。然后题目告诉了一个等式两个不等式。。这个时候我们只要线性规划一下就可以得出几行了,然后就是输出一下,很水。

代码如下

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<map>
#include<list>
#include<climits>
#include<queue>
using namespace std;
int main()
{
	string cur;
	getline(cin, cur);
	int len = cur.size();
	int k;
	if (len <= 7) {
		k = (len - 1) / 2;
	}
	else {
		k = (len + 2) / 3;
	}
	for (int i = 0; i < k; i++) {
			if (i != k - 1) {
				cout << cur[i];
				for (int j = 0; j < len  - 2 * k; j++) {
					cout << " ";
				}
				cout << cur[len - i - 1] << endl;
			}
			else {
				for (int j = 0; j < len-2*k+2; j++) {
					cout << cur[j+k-1];
				}
				cout << endl;
			}
	}
	return 0;
}

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题目大意:类似双向链表,有两条,找这两条的公共部分的开始点。

解题思路:很水的开两个数组,一个记录每个节点的下一个节点地址,另一个记录一下是否访问过。

把第一个单词遍历一遍,把访问过的节点全部标记一下,然后第二个节点开始遍历,如果遇到访问过的,就结束遍历。如果没有,就继续。最后如果是-1,那么就是没有公共部分,如果不是-1那么就是目前的节点。

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
using namespace std;
int map[100005];
bool vist[100005];
int main()
{
	int a1, a2, n;
	cin >> a1 >> a2 >> n;
	memset(map,-1,sizeof(map));
	memset(vist, false, sizeof(vist));
	for (int i = 0; i < n; i++) {
		int a, b;
		char c;
		cin >> a >> c >> b;
		map[a] = b;
	}
	int address = a1;
	while (address != -1) {
		vist[address] = 1;
		address = map[address];
	}
 address = a2;
	while (address != -1 && !vist[address]) {
		address = map[address];
	}
	if (address == -1)cout << -1<<endl;
	else
		printf("%05d\n", address);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值