PAT甲级1031 Hello World for U

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​​ characters, then left to right along the bottom line with n2​​ characters, and finally bottom-up along the vertical line with n3​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1​​ =n​3​​ = max { k | k ≤ n2​​ for all 3 ≤ n2​​ ≤N } with n1 +n2 +n​3​​ −2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

思路

这是一道数学题,根据题目给出的不等式来求得左右两边元素个数。

因为n1 +n2 +n​3​​ −2 = N,所以n2 = N + 2 - n1 - n2 = N + 2 - 2n1
因为n2 >= n1,所以N + 2 - 2n1 >= n1,即3n1 <= N + 2
得n1 <= (N + 2) / 3

所以两边元素个数就是(N + 2) / 3向下取整,然后就方便输出了。

#include <iostream>
#include <cstdlib>
#include <string>
using namespace std;
int main()
{
	string str;
	cin >> str;
	int n1, n2, len = str.size();
	n1 = (len + 2) / 3;
	n2 = len - 2 * n1 + 2;
	int left = 0, right = str.size() - 1;
	for (int i = 0; i < n1 - 1; i++)
	{
		cout << str[left++];
		for (int j = 0; j < n2 - 2; j++) //n2 - 2是中间的空格数
			cout << ' ';
		cout << str[right--] << endl;
	}
	for (int i = left; i <= right; i++)
		cout << str[i];
	system("pause");
	return 0;
}

我第一次还想用平方根的方法来求两边长度,但是abcde这个样例总会输出这样

ae
bd
c
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值