PAT甲级1083,1084解题报告

49 篇文章 0 订阅
47 篇文章 0 订阅

1083 List Grades (25 point(s))

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

题目大意:给一堆学生的列表,给一个成绩的区间,求在这个区间内的学生的列表,按分数从大到小排列。

解题思路:水题,筛选一下排序一下就好了。

#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
#include<stack>
#include<string>
using namespace std;
struct stu
{
	string name;
	string course;
	int grade;
};
stu a[100005];
vector<stu> res;
bool cmp(stu a, stu b) {
	return a.grade > b.grade;
}
int main() {
	int N;
	scanf("%d", &N);
	for (int i = 0; i < N; i++) {
		cin >> a[i].name >> a[i].course >> a[i].grade;
	}
	int ming, maxg;
	scanf("%d %d", &ming, &maxg);
	for (int i = 0; i < N; i++) {
		if (a[i].grade >= ming&&a[i].grade <= maxg)
			res.push_back(a[i]);
	}
	if (res.empty()) {
		printf("NONE\n");
	}
	else {
		sort(res.begin(), res.end(), cmp);
		for (int i = 0; i < res.size(); i++) {
			cout << res[i].name << " " << res[i].course << endl;
		}
	}
	
    
	return 0;
}

1084 Broken Keyboard (20 point(s))

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

题目大意:键盘坏了几个,问你第一个字符串能输出几个值。

解题思路:本来想直接用差集做。。后来发现不行。就抄了个map的题解,也很好懂。

#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
#include<stack>
#include<string>
using namespace std;
int main() {
	string s, ss;
	cin >> s >> ss;
	transform(ss.begin(), ss.end(), ss.begin(), ::toupper); 
	transform(s.begin(), s.end(), s.begin(), ::toupper);
	map<char, int> mp;
	for (int i = 0; i<s.length(); i++) {
		mp[s[i]] = 0;
	}
	for (int i = 0; i<ss.length(); i++) {
		mp[ss[i]] = 1;
	}
	map<char, int> ppp;
	for (int i = 0; i<s.length(); i++) {
		if (mp[s[i]] == 0 && ppp[s[i]] == 0) {
			cout << s[i]; ppp[s[i]] = 1;
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值