HDU 1814 Peaceful Commission 2-sat 输字典序最小的可行解

                                            HDU 1814  Peaceful Commission

The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others.

The Commission has to fulfill the following conditions:
1.Each party has exactly one representative in the Commission,
2.If two deputies do not like each other, they cannot both belong to the Commission.

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party .

Task
Write a program, which:
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms,
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members,
3.writes the result in the text file SPO.OUT.

Input

In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other.
There are multiple test cases. Process to end of file.

Output

The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence.

Sample Input

3 2
1 3
2 4

Sample Output

1
4
5

 

题目大意:

有n个政党,每个政党有2个代表,现在需要组合一个会议,有些代表之间有矛盾,不能共同参会,问是否有可行方案,有则输出字典序最小的方案。

 

题解:

从1-2*N 依次枚举是否能作为方案中的参会人员,如果有矛盾则不行,如果每个政党的第一个不行,则利用模拟栈撤回标记,然后再尝试第二个代表,若两个都不行,则说明无可行参赛方案。

 

#include <bits/stdc++.h>

using namespace std;
const int maxn = 8000 * 2 + 100;
vector <int> G[maxn];
bool used[maxn];
int n,m,top;
int sta[maxn];

bool dfs(int x)
{
	if(used[x^1]) return false;
	if(used[x])   return true;
	used[x] = true;
	sta[top++] = x;
	for(int i = 0; i < G[x].size(); i++)
	  if(!dfs(G[x][i])) return false;
	return true;
}

bool judge()
{
	memset(used,false,sizeof(used));
	for(int i = 0; i < 2*n; i++)
	{
		if(!used[i] && !used[i^1])
		{
			top = 0;
			if(!dfs(i))
			{
				for(int j = 0; j < top; j++)
				   used[sta[j]] = false;
				top = 0;
				if(!dfs(i^1)) return false;
			}
		}
	}
	return true;
}

int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		for(int i = 0; i < 2*n; i++) G[i].clear();
		for(int i = 0; i < m; i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			u--,v--;
			G[u].push_back(v^1);
			G[v].push_back(u^1);
		}
		if(judge())
			{
				for(int i = 0; i < 2*n; i++)
			  if(used[i]) printf("%d\n",i+1);
			}
		else puts("NIE");
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值