POJ 1611 The Suspects

20 篇文章 1 订阅
The Suspects
Time Limit: 1000MS
Memory Limit: 20000K
Total Submissions: 22220
Accepted: 10808

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

题目大意  :一共有n个学生编号0~n-1,给出m组,规定0号学生有传染病,凡是与其在一组的都会被传染
                 要求出最后一共有多少学生会得病

题目分析  :裸的并查集,按秩合并


#include <cstdio>
int const MAX = 30000 + 10;
int rank[MAX];  //秩,表示当前集合中的人数
int father[MAX]; 

void UFset(int n)  //初始化
{
    for(int i = 0; i < n; i++)
    {
        father[i] = i;
        rank[i] = 1;
    }
}

int Find(int x) //查找,路经压缩
{
    return x == father[x] ? x : father[x] = Find(father[x]);
}

void Union(int R1, int R2)   //按秩合并
{
    int r1 = Find(R1);
    int r2 = Find(R2);
    if(r1 == r2)
        return;
    if(rank[r1] <= rank[r2])   //把秩大的作为父亲节点
    {
        father[r1] = r2;
        rank[r2] = rank[r1] + rank[r2];
    }
    else
    {
        father[r2] = r1;
        rank[r1] = rank[r1] + rank[r2];
    }
}

int main()
{
    int n, m;
    while(scanf("%d%d",&n, &m) != EOF && (m + n))
    {
        UFset(n);
        int group, first, next;
        for(int j = 0; j < m; j++)
        {
            scanf("%d%d", &group, &first);
            for(int i = 1; i < group; i++)
            {
                scanf("%d", &next);
                Union(first,next);
            }
        }
        printf("%d\n",rank[Find(father[0])]);  //输出0所属的根节点的秩极为0所在集合的人数
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值