POJ 3041 Asteroids (匈牙利 二分图)

91 篇文章 1 订阅
Asteroids
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 15049
Accepted: 8220

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold


题目链接  :http://poj.org/problem?id=3041


题目大意  :一个n*n的方阵中有m个点上有障碍物,每次可以射击可以去除一整行或者一整列的障碍物,问最多要射击几次


题目分析  :仔细分析发现题目就是求一个二分图中的最小点覆盖, 根据公式最小点覆盖又等于最大匹配数,所以这里直接用匈牙利算法解二分图的最大匹配即可,这里建图是将行当作左边,列当作右边建立二分图,连接障碍物坐标对应的线段,求最大匹配


//裸的匈牙利算法模版,这里不注释了,笔者提醒大家注意初始化的地方
//这题主要难在转化,转化成求最大匹配问题,套模版即可
#include <cstdio>
#include <cstring>
int const MAX = 500 + 1;
int map[MAX][MAX];
int vis[MAX];
int match[MAX];
int n, k;

int DFS(int u)
{
    for(int v = 1; v <= n; v++)
    {
        if(map[u][v] && !vis[v])
        {
            vis[v] = 1;
            if(match[v] == -1 || DFS(match[v]))
            {
                match[v] = u;
                return 1;
            }
        }
    }
    return 0;
}

int hungary()
{
    int ans = 0;
    for(int u = 1; u <= n; u++)
    {
        memset(vis,0,sizeof(vis));
        ans += DFS(u);
    }
    return ans;
}

int main()
{
    int x, y;
    memset(match,-1,sizeof(match));
    memset(map,0,sizeof(map));
    scanf("%d %d",&n, &k);
    for(int i = 0; i < k; i++)
    {
        scanf("%d %d",&x, &y);
        map[x][y] = 1;
    }
    printf("%d\n", hungary());

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值