POJ 2406 Power Strings

70 篇文章 0 订阅
Power Strings
Time Limit: 3000MS
Memory Limit: 65536K
Total Submissions: 32075
Accepted: 13373

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

题目链接  :http://poj.org/problem?id=2406

题目大意  :给一个字符串求其周期子串的个数

题目分析  :用KMP算法中的next数组找周期串

#include <cstdio>
#include <cstring>
int const MAX = 1000000 + 5;
char str[MAX];
int next[MAX];

int cal()
{
    int ans = 1;
    next[0] = -1;
    int k = -1, j = 0;
    while(str[j] != '\0')
    {
        if(k == -1 || str[k] == str[j])
        {
            k++;
            j++;
            next[j] = k;
        }
        else
            k = next[k];
    }
    //这题和Period那题的区别就在这,这题要求原字符串的某一周期子串乘其周期等于原串长
    if(j % (j - next[j]) == 0)  
        ans = j / (j - next[j]);
    return ans;
}

int main()
{
    while(scanf("%s",str) != EOF && !(strlen(str) == 1 && str[0] == '.'))
    {
        memset(next,0,sizeof(next));
        printf("%d\n",cal());
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值