POJ 3518 Prime Gap

78 篇文章 0 订阅
Prime Gap
Time Limit: 5000MS
Memory Limit: 65536K
Total Submissions: 8397
Accepted: 4924

Description

The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbersp andp + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integerk, the length of the prime gap that containsk. For convenience, the length is considered 0 in case no prime gap containsk.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0
114

Source

Japan 2007


题目链接  :http://poj.org/problem?id=3518


题目大意  :两个相邻的素数p和p+n之间n-1个连续合数组成的序列,被称为长度为n的素数间隔。现在给出一个数字k,求包含k的素数间隔的长度


题目分析  :设ans[k]为包含k的素数间隔的长度。若k为素数,ans[k] = 0,若k为合数且k位于素数p1,p2之间,则k所在合数区间内每个合数的ans值都为同一个数,及ans[p1 + 1] = ans[p1 + 2]... = ans[p2 - 1] = (p2 - 1) - (p1 + 1) + 2
我们可以先得到素数筛prime[],然后开始从2枚举,若为合数则计算区间[i,j]否则为0。



#include <cstdio>
#include <cstring>
int const MAX = 1299710;
bool prime[MAX];
int ans[MAX];

//离线计算出题目范围内每个数所在的素数间隔长度
void pre()
{
    //先用筛选法得到素数筛
    int i, j, k;
    prime[1] = false;
    for(i = 2; i < MAX; i++)
        prime[i] = true;
    for(i = 2; i < MAX; i++)
        if(prime[i])
            for(j = i << 2; j < MAX; j += i)
                prime[j] = false;
    //枚举2到MAX - 1的没一个数,若为合数计算区间[i,j],否则值为0
    for(i = 2; i < MAX; i++)
    {
        if(!prime[i]) //如果不是素数
        {
            j = i;
            //计算累积量
            while(j < MAX && !prime[j])
                j++;
            j--;
            //置合数区间内每个合数的ans值
            for(k = i; k <= j; k++)
                ans[k] = j - i + 2;
            i = j; //还原i的值
        }
        else //如果是素数ans值为0
            ans[i] = 0;
    }
}

int main()
{
    pre();
    int k;
    while(scanf("%d", &k) != EOF && k)
        printf("%d\n", ans[k]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值