POJ 1979 Red and Black (裸BFS)

66 篇文章 0 订阅
Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 22754 Accepted: 12284

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source


题目链接  :http://poj.org/problem?id=1979


题目大意  :给个m*n的矩阵和一个起点,问最多能遍历多少格子


题目分析  :裸bfs,dfs也可,博文也写了


#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int const MAX = 22;
char map[MAX][MAX];
int vis[MAX][MAX];
int n, m;
int step;
int dirx[4] = {1, 0, -1, 0};
int diry[4] = {0, 1, 0, -1};
struct node
{
    int x, y;
};
node start;
queue<node> q;

void bfs()
{
    q.push(start);
    while(!q.empty())
    {
        node cur = q.front();
        node next;
        q.pop();
        for(int i = 0; i < 4; i++)
        {
            next.x = cur.x + dirx[i];
            next.y = cur.y + diry[i];
            if(next.x < 0 || next.y < 0 || next.x >= n || next.y >= m)
                continue;
            if(map[next.x][next.y] == '#' || vis[next.x][next.y])
                continue;
            vis[next.x][next.y] = 1;
            step++;
            q.push(next);
        }
    }

}

int main()
{
    while(scanf("%d %d", &m, &n) != EOF && (n + m))
    {
        step = 1;
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i < n; i++)
        {
            scanf("%s", map[i]);
            for(int j = 0; j < m; j++)
            {
                if(map[i][j] == '@')
                {
                    start.x = i;
                    start.y = j;
                    vis[i][j] = 1;
                }
            }
        }
        bfs();
        printf("%d\n", step);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值