HDU 5527 Too Rich (好题 贪心 DFS)

66 篇文章 0 订阅
34 篇文章 3 订阅

Too Rich

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 228    Accepted Submission(s): 69

Problem Description
You are a rich person, and you think your wallet is too heavy and full now. So you want to give me some money by buying a lovely pusheen sticker which costs  p dollars from me. To make your wallet lighter, you decide to pay exactly  p  dollars by as many coins and/or banknotes as possible.

For example, if  p=17  and you have two  $10  coins, four  $5  coins, and eight  $1  coins, you will pay it by two  $5  coins and seven  $1  coins. But this task is incredibly hard since you are too rich and the sticker is too expensive and pusheen is too lovely, please write a program to calculate the best solution.
 

Input
The first line contains an integer  T  indicating the total number of test cases. Each test case is a line with 11 integers  p,c1,c5,c10,c20,c50,c100,c200,c500,c1000,c2000 , specifying the price of the pusheen sticker, and the number of coins and banknotes in each denomination. The number  ci  means how many coins/banknotes in denominations of  i  dollars in your wallet.

1T20000
0p109
0ci100000
 

Output
For each test case, please output the maximum number of coins and/or banknotes he can pay for exactly  p  dollars in a line. If you cannot pay for exactly  p  dollars, please simply output '-1'.
 

Sample Input
  
  
3 17 8 4 2 0 0 0 0 0 0 0 100 99 0 0 0 0 0 0 0 0 0 2015 9 8 7 6 5 4 3 2 1 0
 

Sample Output
  
  
9 -1 36
 

Source
 


题目大意:有1,5,10,20,50,100,200,500,1000,2000十种面值的钱币各ci个,现在要凑出p元,问最多可以用多少钱币凑出

题目分析:长春的金牌题。。。首先按贪心的思想,用尽可能多的小面值钱币,前提是小面值钱币可以凑出当前需要的钱数,所以从大面值的开始决策,比如现在到第idx个面值的钱币,要凑x元,又用1~idx-1的钱币可以凑出的总金额为y元,那么当前面值我需要用(x - y) / c[i]个,当然如果这个值小于0,就不用当前面值的钱币,注意如果c[i]不能整除(x- y),则需要多用一个idx的钱币,因为剩下的钱不够,比如有 10 20 20 50 50,现在要凑110,110 - 10 - 20 - 20 = 60,50不能整除60,则就需要两个50的,因为只用一个50的话,剩下的凑不出60,还有一点要注意的是20不能整除50,200不能整除500,因此我们算个数的时候有时需要多加一个,比如20 20 20 50,现在要凑50,因为剩下3个20,一共可以凑60,按照贪心策略那个单独的50就不会被选了,因此这里需要强制选一个50,200和500同理
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int p, ans, c[11];
int val[11] = {0, 1, 5, 10, 20, 50, 100, 200, 500, 1000, 2000}; 
ll sum[11];

void DFS(int rest, int idx, int cnt)
{
    if(rest < 0)
        return;
    if(idx == 0)
    {
        if(rest == 0)
            ans = max(ans, cnt);
        return;
    }
    ll cur = max(rest - sum[idx - 1], 0ll);
    int curnum = cur / val[idx];
    if(cur % val[idx])
        curnum ++;
    if(curnum <= c[idx])
        DFS(rest - curnum * val[idx], idx - 1, cnt + curnum);
    curnum ++;
    if(curnum <= c[idx])
        DFS(rest - curnum * val[idx], idx - 1, cnt + curnum);
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T --)
    {
        memset(sum, 0, sizeof(sum));
        ans = -1;
        scanf("%d", &p);
        for(int i = 1; i <= 10; i++)
            scanf("%d", &c[i]);
        for(int i = 1; i <= 10; i++)
            sum[i] = sum[i - 1] + (ll)(val[i] * c[i]);
        DFS(p, 10, 0);
        printf("%d\n", ans);
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值