POJ 1050 To the Max (最大子矩阵)

To the Max
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 41297
Accepted: 21905

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

Greater New York 2001


题目链接 :http://poj.org/problem?id=1050


题目大意 :给出一个n * n的方阵,求其子矩阵的各个元素和的最大值

题目分析 :最大连续和的二维情况,可以枚举行的组合,然后对组合出来的情况用一维求解

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 105;
int const INF = 0x3fffffff;
int num[MAX][MAX], b[MAX];
int n;

int MaxSum1() {
    int ma = -INF, cur = 0;
    for (int i = 1; i <= n; i ++) {
        cur += b[i];       
        if(cur > ma) {      
            ma = cur;
        }
        if(cur < 0) {
            cur = 0;
        }
    }
    return ma;
}

int MaxSum2() {
    int ma = -INF;                      
    for (int i = 1; i <= n; i ++) {
        memset(b, 0, sizeof(b));
        for (int j = i; j <= n; j ++) {
            for (int k = 1; k <= n; k ++) {
                b[k] += num[j][k];        
            }
            ma = max(ma, MaxSum1());
        }
    }                      
    return ma;
}

int main() {
    scanf("%d", &n);
    for (int i = 1; i <= n; i ++) {
        for (int j = 1; j <= n; j ++) {
            scanf("%d", &num[i][j]);
        }
    }
    printf("%d\n", MaxSum2());
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值