POJ 3624 Charm Bracelet (线性dp 0/1背包)


Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24286 Accepted: 10952

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from theN (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factorDi (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more thanM (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N andM
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver


题目链接 :http://poj.org/problem?id=3624

题目大意 : n种珠宝,每个珠宝有个重量w[i],价值d[i],求在重量不超过m的情况下的最大价值,(每个珠宝只能买一次)

题目分析:裸的0/1背包,dp[i][j]表示将前i个珠宝恰放入容量为j的背包时的最大价值则
dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - w[i]] + d[i]),空间压缩后: (w[i] <= k <= m)  dp[k] = max(dp[k], dp[k - w[i]] + d[i])

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int w[3403], v[3403];
int dp[12881];
int main()
{
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF)
    {
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++)
            scanf("%d %d", &w[i], &v[i]);
        for(int i = 1; i <= n; i++)
            for(int tot = m; tot >= w[i]; tot--)
                dp[tot] = max(dp[tot], dp[tot - w[i]] + v[i]);
        printf("%d\n", dp[m]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值