POJ 1416 Shredding Company (DFS+构造)

66 篇文章 0 订阅


Shredding Company

Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 4398
Accepted: 2520

Description

You have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics. 

1.The shredder takes as input a target number and a sheet of paper with a number written on it. 
2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it. 
3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it. 

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50. 
 
Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50


There are also three special rules : 
1.If the target number is the same as the number on the sheet of paper, then the paper is not cut. 
For example, if the target number is 100 and the number on the sheet of paper is also 100, then 
the paper is not cut. 

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed. 

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number. 

Input

The input consists of several test cases, each on one line, as follows : 
tl num1 
t2 num2 
... 
tn numn 
0 0 
Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded. 
Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input. 

Output

For each test case in the input, the corresponding output takes one of the following three types : 
sum part1 part2 ... 
rejected 
error 

In the first type, partj and sum have the following meaning : 
1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper. 
2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +... 
Each number should be separated by one space. 
The message error is printed if it is not possible to make any combination, and rejected if there is 
more than one possible combination. 
No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line. 

Sample Input

50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0

Sample Output

43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected

Source

Japan 2002 Kanazawa



题目大意:输入两个数n和t,将数字t分解求和,求所得到的小于等于n并最接近n的解,并输出分解方案,如果不存在这样的分解输出error,如果有多组解输出rejected

分析第一组样例:50  12346,其最优分解为1 2 34 6,和为43
第七组样例:111 33333,其最优分解为33 33 3或者3 33 33不唯一,故输出rejected

题目分析:易得最小分解和为把每位数字都拆分下来求和,若这时候和依旧大于n则无解,若n与t相等,则直接输出n
对于其他情况,数字要用字符串存,因为要考虑前导0,题目说的Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. 是针对输入而言的,搜索时我们采用类似两点法的思想,DFS中有三个参数sum表示当前的和,st和ed分别表示当前分解位置的头和尾,每次搜索时我们通过st和ed来得到当前分解出来的数字cur,对于要输出的解我们可以通过对下标位的标记来实现,即若从某位开始要拆则该位标记为true,
如果不拆,则DFS(sum,st,ed+1)表示当前和不变,ed向后扩一位,
如果拆,    则DFS(sum+cur,ed,ed+1)表示当前位拆分,和加上cur,下一次搜索的头位置为当前的尾位置
当ed=len时,一次分解策略结束
若比之前的和大,则更新ans,跟新ans时rejected要设置为false,因为才更新的时候最优的ans只有一个,即为刚更新的值
若与之前相同。则rejected标记为true,表示当前最优解不止一种分解法

#include <cstdio>
#include <cstring>
int n, len, ans;
char s[10];
bool rejected;
bool mark[10], tmark[10];

//当前的和,当前数字的头下标,当前数字的尾下标
void DFS(int sum, int st, int ed)
{
    if(sum > n)
        return;
    int cur = 0;
    for(int i = st; i < ed; i++)
    {
        cur *= 10;
        cur += (s[i] - '0');
    }
    if(ed == len)
    {
        sum += cur;
        if(sum <= n && ans >= 0)
        {
            if(ans < sum)
            {
                ans = sum;
                rejected = false;
                for(int i = 0; i < len; i++)
                    mark[i] = tmark[i];
            }
            else if(sum == ans)
                rejected = true;
        }
        return;
    }
    tmark[ed] = false;
    DFS(sum, st, ed + 1); //不拆
    tmark[ed] = true;
    DFS(sum + cur, ed, ed + 1) ;//拆
}

int main()
{
    int t;
    while(scanf("%d %d", &n, &t) && (n + t))
    {
        rejected = false;
        int tmp = t, sum = 0;
        while(tmp)
        {
            sum += (tmp % 10);
            tmp /= 10;
        }
        if(sum > n)
        {
            printf("error\n");
            continue;
        }
        if(n == t)
        {
            printf("%d %d\n", n, n);
            continue;
        }
        sprintf(s, "%d", t);    
        len = strlen(s);
        ans = 0;
        tmark[0] = true;
        DFS(0, 0, 1);
        if(rejected)
            printf("rejected\n");
        else if(ans > 0)
        {
            printf("%d", ans);
            for(int i = 0; i < len; i++)
            {
                if(mark[i])
                    printf(" ");
                printf("%c", s[i]);
            }
            printf("\n");
        }
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值