HDU 3006 The Number of set (状态压缩+hash)

177 篇文章 0 订阅
68 篇文章 4 订阅


The Number of set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1181    Accepted Submission(s): 722


Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
 

Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
 

Output
For each case,the output contain only one integer,the number of the different sets you get.
 

Sample Input
  
  
4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
 

Sample Output
  
  
15 2
 

Source
2009 Multi-University Training Contest 11 - Host by HRBEU

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3006

题目大意:给你n个集合,问用这些集合合并能组成多少新的集合

题目分析:好题,因为m只有14,我们可以采用状态压缩,1表示该位置有数字,0表示没有,例如1 2 3这个集合,111代表其状态,我们先把所给集合的状态都用hash存下来,然后通过让它们进行与运算,得到的结果也用hash存下来,最后只要通过hash计算一下有多少种状态即可

#include <cstdio>
#include <cstring>
int const MAX = 1 << 15;
bool hash[MAX];

int main()
{
    int n, m, len = 1 << 14;
    while(scanf("%d %d", &n, &m) != EOF)
    {
        int cnt = 0;
        memset(hash, false, sizeof(hash));
        while(n--)
        {
            int k, get, cur = 0;
            scanf("%d", &k);
            while(k--)
            {
                scanf("%d", &get);
                cur = cur | (1 << (get - 1));
            }
            hash[cur] = true;
            for(int i = 0; i <= len; i++)
                if(hash[i])
                    hash[i | cur] = true;
        }
        for(int i = 0; i <= len; i++)
            if(hash[i])
                cnt++;
        printf("%d\n", cnt);
    }
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值