Song Jiang's rank list
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 392 Accepted Submission(s): 193
Problem Description
《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.
In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
Input
There are no more than 20 test cases.
For each test case:
The first line is an integer N (0<N<200), indicating that there are N outlaws.
Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique.
The next line is an integer M (0<M<200) ,indicating that there are M queries.
Then M queries follow. Each query is a line containing an outlaw's name.
The input ends with n = 0
For each test case:
The first line is an integer N (0<N<200), indicating that there are N outlaws.
Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique.
The next line is an integer M (0<M<200) ,indicating that there are M queries.
Then M queries follow. Each query is a line containing an outlaw's name.
The input ends with n = 0
Output
For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed.
Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
Sample Input
5 WuSong 12 LuZhishen 12 SongJiang 13 LuJunyi 1 HuaRong 15 5 WuSong LuJunyi LuZhishen HuaRong SongJiang 0
Sample Output
HuaRong 15 SongJiang 13 LuZhishen 12 WuSong 12 LuJunyi 1 3 2 5 3 1 2
Source
题目大意:给一些人名和分数,每个人有两个额外值,第一个是分数比自己高且排名在自己前面的人数+1,第二个是分数和自己相同且排名在自己前面的人数+1,输出时先输出排名,再输出每个人的两个额外值,若第二个为1,则不需要输出
题目分析:排排序模拟一下就好
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct PERSON
{
char name[55];
int k;
int r1, r2;
}p[55];
bool cmp(PERSON a, PERSON b)
{
if(a.k == b.k)
return strcmp(a.name, b.name) < 0;
return a.k > b.k;
}
int main()
{
int n, m;
char get[55];
while(scanf("%d", &n) != EOF && n)
{
for(int i = 0; i < n; i++)
scanf("%s %d", p[i].name, &p[i].k);
sort(p, p + n, cmp);
for(int i = 0; i < n; i++)
printf("%s %d\n", p[i].name, p[i].k);
int cnt = 1;
p[0].r1 = 1;
p[0].r2 = 1;
for(int i = 1; i < n; i++)
{
if(p[i].k < p[i - 1].k)
p[i].r1 = i + 1;
if(p[i].k == p[i - 1].k)
{
p[i].r1 = p[i - 1].r1;
p[i].r2 = ++cnt;
}
else
{
cnt = 1;
p[i].r2 = cnt;
}
}
scanf("%d", &m);
for(int i = 0; i < m; i++)
{
scanf("%s", get);
for(int j = 0; j < n; j++)
if(strcmp(p[j].name, get) == 0)
if(p[j].r2 == 1)
printf("%d\n", p[j].r1);
else
printf("%d %d\n", p[j].r1, p[j].r2);
}
}
}