HDU 5131 Song Jiang's rank list(水题)

Song Jiang's rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1463    Accepted Submission(s): 808


Problem Description
《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
 
Input
There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique. 

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw's name. 
The input ends with n = 0
 
Output
For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed. 

Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
 
Sample Input
      
      
5
WuSong 12
LuZhishen 12
SongJiang 13
HuaRong 15
LuJunyi 1
5 WuSong
HuaRong
LuJunyi LuZhishen
0
SongJiang

Sample Output
      
      
HuaRong 15
SongJiang 13
LuZhishen 12
LuJunyi 1
WuSong 12
3 2 5 3 1
2
 
Source

题意:给定一串人名和相应分数,先输出排序,然后针对每次查询,输出该人的major rank(即比该人分数高的人数+1)和minor rank(即和该人分数一样但姓名字母顺序小的人数+1)。
思路:水题。想法很好,敲得很快,然而还是不会用char数组,悲催的WA了无数次,最后改成string就A了。满服气的。
#include <iostream>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;


struct node{
    string s;
    int score;
}d[305];

bool cmp(node a,node b){
    if(a.score!=b.score)
        return b.score<a.score;
    else
        return a.s<b.s;
}

int main(){
    
    int n;
    while(~scanf("%d",&n)){
        map<string,int> mar; 
        map<string,int> mjr;
        if(n==0)
            break;
        for(int i=0;i<n;i++){
            cin>>d[i].s;
            scanf("%d",&d[i].score);
        }
        sort(d,d+n,cmp);
        for(int i=0;i<n;i++){
            cout<<d[i].s<<' ';
            printf("%d\n",d[i].score); 
        }
        for(int i=1;i<n;i++){
            int k=i-1;
            int cnt=0;
            while(d[k].score==d[i].score){
                if(k<0){
                    break;
                }
                k--;
                cnt++;
            } 
            string s=d[i].s;
            mjr[s]=cnt+1;
            mar[s]=i+1-cnt;
        }
        mar[d[0].s]=1;
        mjr[d[0].s]=1;
        int t;
        scanf("%d",&t);
        while(t--){
            char c1[60];
            scanf("%s",c1);
            if(mjr[c1]==1)
                printf("%d\n",mar[c1]);
            else
                printf("%d %d\n",mar[c1],mjr[c1]);
        }
    }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值