POJ 2075 Tangled in Cables (kruskal算法 MST + map)

91 篇文章 1 订阅


Tangled in Cables
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6039 Accepted: 2386

Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

Input

Only one town will be given in an input.
  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).

Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

Sample Output

Need 10.2 miles of cable

Source

Mid-Atlantic 2004


题目链接:poj.org/problem?id=2075

题目大意:给一个总线长,和n个人,m组关系,表示两个人之间的距离,现在要求所有人之间都连通,问最少需要多长的线,若超过总长,则输出Not enough cable

题目分析:裸最小生成树问题,直接map一下字符串,再跑一下Kruskal

#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
#include <iostream>
using namespace std;
int const MAX = 1e4;

int fa[MAX];
int re[MAX];
int n, m;
map<string, int> mp;

struct Edge
{
    int u, v;
    double w;
}e[MAX];

bool cmp(Edge a, Edge b)
{
    return a.w < b.w;
}

void UF_set()
{
    for(int i = 0; i < MAX; i++)
        fa[i] = i;
}

int Find(int x)
{
    return x == fa[x] ? x : fa[x] = Find(fa[x]);
}

void Union(int a, int b)
{
    int r1 = Find(a);
    int r2 = Find(b);
    if(r1 != r2)
        fa[r2] =r1;
}

double Kruskal()
{
    UF_set();
    int num = 0;
    double res = 0;
    for(int i = 0; i < m; i++)
    {
        int u = e[i].u;
        int v = e[i].v;
        if(Find(u) != Find(v))
        {
            Union(u, v);
            res += e[i].w;
            num ++;
        }
        if(num >= n - 1)
            break;
    }
    return res;
}

int main()
{
    string s, s1, s2;
    double val, sum, ans = 0;
    scanf("%lf", &sum);
    int cnt = 1;
    mp.clear();
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        cin >> s;
        if(!mp[s])
            mp[s] = cnt ++;
    }
    scanf("%d", &m);
    for(int i = 0; i < m; i++)
    {
        cin >> s1 >> s2 >> val;
        e[i].u = mp[s1];
        e[i].v = mp[s2];        
        e[i].w = val;
    }
    sort(e, e + m, cmp);
    ans = Kruskal();
    if(ans < sum)
        printf("Need %.1f miles of cable\n", ans);
    else
        printf("Not enough cable\n");
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值