POJ 1325 Machine Schedule (二分图最小点集覆盖 匈牙利算法)

91 篇文章 1 订阅

Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12621 Accepted: 5399

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source

Beijing 2002

题目链接:http://poj.org/problem?id=1325

题目大意:两个机器,每个作业可以在不同机器的不同模式下工作,A x y表示作业A可以由机器1的x模式或者机器2的y模式完成,要完成所有作业,必须不断切换机器模式,试寻找适合的分配关系使得切换次数最小,注意机器1和机器2开始都工作在0模式,求最小次数

题目分析:二分图最小点集覆盖问题,1和2两个机器作为二分图的两边,按每个工作对应的1,2机器模式建边,然后就是求这个二分图的最小点覆盖,即最小的点集,使得其包含所有的边,根据二分图的最小点集覆盖数=最大匹配,所以直接用匈牙利算法求解最大匹配即可,注意0模式时不要连边即可

#include <cstdio>
#include <cstring>
int const MAX = 105;
bool g[MAX][MAX];
int cx[MAX], cy[MAX];
bool vis[MAX];
int n, m, k;

int DFS(int x)
{
    for(int y = 0; y < m; y++)
    {
        if(!vis[y] && g[x][y])
        {
            vis[y] = true;
            if(cy[y] == -1 || DFS(cy[y]))
            {
                cx[x] = y;
                cy[y] = x;
                return 1;
            }
        }
    }
    return 0;
}

int MaxMatch()
{
    int res = 0;
    memset(cx, -1, sizeof(cx));
    memset(cy, -1, sizeof(cy));
    for(int i = 0; i < n; i++)
    {
        if(cx[i] == -1)
        {
            memset(vis, false, sizeof(vis));
            res += DFS(i);
        }
    }
    return res;
}

int main()
{
    while(scanf("%d", &n) != EOF && n)
    {
        memset(g, false, sizeof(g));
        scanf("%d %d", &m, &k);
        for(int i = 0; i < k; i++)
        {
            int tmp, x, y;
            scanf("%d %d %d", &tmp, &x, &y);
            if(x * y)
                g[x][y] = true;
        }
        int ans = MaxMatch();
        printf("%d\n", ans);
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值