数据结构篇(二分图)最小点覆盖poj1325

二分图中,找到最少点覆盖,所有相关联的边就叫最小点覆盖.

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
Output
The output should be one integer per line, which means the minimal times of restarting machine.
Sample Input
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0
Sample Output
3

题目两个模式,即为二分图的两个点集,那么对应的用两个模式去解决工作,那么也就是说,这两个点相连,要找出最少改变模式次数,也就是说找出最少的点,使它们所有的边都被覆盖,那么用到konig定理:最小点覆盖数=最大匹配数,直接模板往上套就可以了。

题目注意起始是0,那么对于所有工作有0的,即不需要改变模式,我们可以舍弃含有0的点,从1- n-1遍历,注意循环的时候要清空map数组

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <cstdio>
using namespace std;
int vis[109];
int map[109][109];
int link[109];
int n,m;
int dfs(int a)
{
    int i;
    for(i=1; i<=m-1; i++)
    {
        if(map[a][i]&&!vis[i])
        {
            vis[i]=1;
            if(link[i]==0||dfs(link[i]))
            {
                link[i]=a;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int k,a,b,i,j,c;
    while(scanf("%d",&n)&&n!=0)
    {
        memset(link,0,sizeof(link));
        memset(map,0,sizeof(map));
        scanf("%d%d",&m,&k);
        while(k--)
        {
            scanf("%d%d%d",&c,&a,&b);
            map[a][b]=1;
        }
        int ans=0;
        for(i=1; i<=n-1; i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))
            {
                ans++;
            }
        }
        printf("%d\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值