HDU 4632 Palindrome subsequence (区间dp 容斥定理)

177 篇文章 0 订阅
70 篇文章 0 订阅


Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)

Total Submission(s): 2610    Accepted Submission(s): 1050

Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, ..., Sxk> and Y = <Sy1, Sy2, ..., Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
  
  
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
  
  
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
 

Source
2013 Multi-University Training Contest 4

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4632

题目大意:给一个字符串,求其所有回文子串的个数,字符位置不同属于不同的回文子串

题目分析:很熟悉的一道dp,貌似是编程之美资格赛的一题,原来是曾经多校的原题啊。。。我们从左向右枚举区间,对于每个区间从外向内算,dp[i][j]表示从i到j的子串中回文子串的个数如果s[i] == s[j],则dp[i][j] += dp[i - 1][j + 1] + 1,另外dp[i][j] = dp[i - 1][j] + dp[i][j + 1] - dp[i - 1][j + 1],这里相当于一个容斥,去掉重复的部分,最后的答案为dp[len][1]


#include <cstdio>
#include <cstring>
int const MAX = 1005;
int const MOD = 10007;
char s[MAX];
int dp[MAX][MAX];

int main()
{
    int T;
    scanf("%d", &T);
    for(int ca = 1; ca <= T; ca++)
    {
        printf("Case %d: ", ca);
        memset(dp, 0, sizeof(dp));
        scanf("%s", s + 1);
        int len = strlen(s + 1);
        for(int i = 1; i <= len; i++)
        {
            for(int j = i; j >= 1; j--)
            {
                if(i == j)
                {
                    dp[i][j] = 1;
                    continue;
                }
                if(s[i] == s[j])
                    dp[i][j] += dp[i - 1][j + 1] + 1;
                dp[i][j] += (5 * MOD + dp[i - 1][j] + dp[i][j + 1] - dp[i - 1][j + 1]) % MOD;
            }
        }
        printf("%d\n", dp[len][1] % MOD);
    }
}




 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值