HDU 4135 Co-prime (分解质因数 + 容斥)

78 篇文章 0 订阅
56 篇文章 0 订阅


Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2314    Accepted Submission(s): 865

Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 
Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 1015) and (1 <=N <= 109).
 
Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 
Sample Input
  
  
2 1 10 2 3 15 5
 
Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 
Source
The Third Lebanese Collegiate Programming Contest


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4135

题目大意:求区间[A,B]内由多少数字与N互质

题目分析:先预处理出N的质因子,开始开的1e5,wa死,开到5e5就过了,算出[A,B]内有多少数字不与N互质,拿总数减即可,计算不互质的数的个数先把区间转化为[1,a-1]和[1,b]然后直接容斥搞


#include <cstdio>
#include <cstring>
#define ll long long
int const MAX = 5e5 + 5;
int fac[MAX];
int cnt;
ll a, b, n, num1, num2;

void get_factor(ll x)
{
    cnt = 0;
    for(int i = 2; i * i < MAX; i++)
    {
        if(x % i == 0)
        {
            fac[cnt ++] = i;
            while(x % i == 0)
                x /= i;
        }
    }
    if(x > 1)
        fac[cnt ++] = x;
}   

void DFS(int idx, ll cur, int sgin, ll s, bool f)
{
    for(int i = idx; i < cnt; i++)
    {
        ll tmp = (ll) cur * fac[i];
        if(f)
            num1 += (ll) sgin * (s / tmp);
        else
            num2 += (ll) sgin * (s / tmp);
        DFS(i + 1, tmp, -sgin, s, f);
    }
}

int main()
{
    int T;
    scanf("%d", &T);
    for(int ca = 1; ca <= T; ca++)
    {
        scanf("%I64d %I64d %I64d", &a, &b, &n);
        get_factor(n);
        num1 = 0;
        DFS(0, 1, 1, b, 1);
        num2 = 0;
        DFS(0, 1, 1, a - 1, 0);
        ll ans = (ll)b - a + 1 - (num1 - num2);
        printf("Case #%d: %I64d\n", ca, ans);
    }
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值