hdu-5428The Factor(质因数分解)

The Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3117    Accepted Submission(s): 965

Problem Description

There is a sequence of n positive integers. Fancycoder is addicted to learn their product, but this product may be extremely huge! However, it is lucky that FancyCoder only needs to find out one factor of this huge product: the smallest factor that contains more than 2 factors(including itself; i.e. 4 has 3 factors so that it is a qualified factor). You need to find it out and print it. As we know, there may be none of such factors; in this occasion, please print -1 instead. 

Input

The first line contains one integer T (1≤T≤15), which represents the number of testcases. 

For each testcase, there are two lines:

1. The first line contains one integer denoting the value of n (1≤n≤100).

2. The second line contains n integers a1,…,an (1≤a1,…,an≤2×109), which denote these n positive integers. 

Output

Print T answers in T lines.

Sample Input

2 3 1 2 3 5 6 6 6 6 6

Sample Output

6 4

思路

虽然每个数那么大,但是对于每个数字,只有它们的质因子是有用的,所以我们只需要把每个质因子分解,然后对它们排序,然后找出两个最小的相乘就好了。如果所有的所有数字的质因子个数小于2个,那么就是无解。

AC Code

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e2+5;
vector<ll>res;
ll a[maxn];
int main() {
	ll t,n,flag;
	scanf("%lld",&t);
	while(t--){
		scanf("%lld",&n);
		for(int i=0;i<n;i++) {
			scanf("%lld",&a[i]);
			for(ll j=2;j<=sqrt(a[i]);j++){
				while(a[i]%j==0){
					a[i]/=j;
					res.push_back(j);
				}
			}
			if(a[i] != 1) res.push_back(a[i]);
		}
		sort(res.begin(),res.end());
		if(res.size()<2) printf("-1\n");
		else printf("%lld\n",res[0]*res[1]);
		res.clear();
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值