HDU 2685 I won't tell you this is about number theory (数论 公式 快速幂取模)

78 篇文章 0 订阅


I won't tell you this is about number theory

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 376    Accepted Submission(s): 103


Problem Description

To think of a beautiful problem description is so hard for me that let's just drop them off. :)
Given four integers a,m,n,k,and S = gcd(a^m-1,a^n-1)%k,calculate the S.

Input
The first line contain a t,then t cases followed.
Each case contain four integers a,m,n,k(1<=a,m,n,k<=10000).
 
Output
One line with a integer S.
 
Sample Input
  
  
1 1 1 1 1
 
Sample Output
  
  
0

Source
 
题目大意:求gcd(a^m-1,a^n-1)%k

题目分析:


更一般的公式:
gcd(A, B) = 1  => gcd(A^m - B^m,A^n - B^n)= A^gcd(m,n) - B^gcd(m,n)


#include <cstdio>
int a, m, n, MOD;

int gcd(int a, int b)
{
    return b ? gcd(b, a % b) : a;
}

int qpow(int x, int n)
{
    int res = 1;
    while(n)
    {
        if(n & 1)
            res = (res * x) % MOD;
        x = (x * x) % MOD;
        n >>= 1;
    }
    return res;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T --)
    {
        scanf("%d %d %d %d", &a, &m, &n, &MOD);
        printf("%d\n", (MOD + qpow(a, gcd(n, m)) % MOD - 1 % MOD) % MOD);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值