Find a way

Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input
4 4
Y.#@
….
.#..
@..M
4 4
Y.#@
….
.#..
@#.M
5 5
Y..@.
.#…
.#…
@..M.

Sample Output
66
88
66
两个人初始位置是y和m,@代表咖啡馆,求哪个咖啡馆总用时最少。先搜y,然后找每个@的ans1时间,首先他还得能访问到,所以加一个leap数组,然后就是ans2,重复操作,记得初始化,最后找最小值就好了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
char a[205][205];
int leap[205][205], m, n, x1, yo, x2, y2, num, time;
int dir[4][2] = { 1, 0, -1, 0, 0, 1, 0, -1 };
int dp[205][205];
struct Node{
    int x;
    int y;
    int ans1;
    int ans2;
    int leap;
}node[4050];
queue<Node>p;
int min(int a, int b)
{
    return a < b ? a : b;
}
void bfs(int x1,int y1)
{
    Node temp, now;
    int i, tempx, tempy;
    temp.x = x1; temp.y = y1; p.push(temp);
    memset(leap, 0, sizeof(leap));
    leap[x1][y1] = 1;
    dp[x1][y1] = 0;
    while (p.size())
    {
        temp = p.front();
        for (i = 0; i < 4; i++)
        {
            tempx = temp.x + dir[i][0];
            tempy = temp.y + dir[i][1];
            if (tempx >= 1 && tempx <= n&&tempy >= 1 && tempy <= m)
            {
                if (!leap[tempx][tempy] && a[tempx][tempy] != '#')
                {
                    leap[tempx][tempy] = 1;
                    now.x = tempx; now.y = tempy;
                    dp[tempx][tempy] = dp[temp.x][temp.y] + 1;
                    p.push(now);
                }
            }
        }
        p.pop();
    }
}
int main()
{
    int i, j, ans, k, time1, time2;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        getchar(); k = 0;
        for (i = 1; i <= n; i++)
        {
            for (j = 1; j <= m; j++)
            {
                cin >> a[i][j];
                if (a[i][j] == 'Y')
                {
                    x1 = i; yo = j;
                }
                if (a[i][j] == 'M')
                {
                    x2 = i; y2 = j;
                }
                if (a[i][j] == '@')
                {
                    k++;
                    node[k].x = i; node[k].y = j; node[k].leap = 1;
                }
            }
            getchar();
        }
        num = k;
        time = 999;
        bfs(x1, yo);
        for (i = 1; i <= num; i++)
        if (leap[node[i].x][node[i].y])
            node[i].ans1 = dp[node[i].x][node[i].y];
        else
            node[i].leap = 0;
        bfs(x2, y2);
        for (i = 1; i<= num; i++)
        if (leap[node[i].x][node[i].y])
            node[i].ans2 = dp[node[i].x][node[i].y];
        else
            node[i].leap = 0;
        for (i = 1; i <= num; i++)
        {
            if (node[i].leap == 0)continue;
            time = min(time, node[i].ans1 + node[i].ans2);
        }
        cout << time*11 << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值