杭电oj1002

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 533030 Accepted Submission(s): 101879

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

Recommend
We have carefully selected several similar problems for you: 1004 1003 1008 1005 1089

#include<bits/stdc++.h>
using namespace std;
int main()
{
    long long int n,m=1,a[1010],b[1010],c[1010],t,A1,B1,u,p=0;

    string A,B;
    cin>>n;
    u=n;
    while(n--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        t=0;
        cin>>A>>B;
        A1=A.length();
        B1=B.length();
        for(long long int i=A1-1;i>=0;i--)
        {
               a[i]=A[A1-1-i]-'0';

        }
        for(long long int j=B1-1;j>=0;j--)
        {
               b[j]=B[B1-1-j]-'0';
        }

        if(A1>=B1)
            t=A.length();
        else
            t=B.length();
        for(long long int k=0;k<=t;k++)
        {
            c[k]=(a[k]+b[k]+p)%10;
            p=(a[k]+b[k]+p)/10;
        }
        cout<<"Case "<<m<<":"<<endl;
        cout<<A<<" + "<<B<<" = ";
        if(c[t]!=0)
        {
            for(long long int s=t;s>=0;s--)
                cout<<c[s];
                if(m==u)
                cout<<endl;
                else
                cout<<endl<<endl;
        }

        else
        {
            for(long long int s=t-1;s>=0;s--)
                cout<<c[s];
                if(m==u)
                cout<<endl;
                else
                cout<<endl<<endl;
        }
        m++;

    }



}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值