用记忆化搜索的方法做01背包题

     今天看题的时候,看到了早就做过的01背包题,想想当时刚开始学的时候,用的是记忆化搜索,这种方法对时间复杂度上的要求比较高,相信很多大牛们都不用了吧,但我还是写了一下,算是一种加强记忆吧,以后有想看的也可以在这里找到:

一道hdu上的01背包裸题:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41109    Accepted Submission(s): 17110


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 

下面是AC代码:更高效的01背包代码网上挺多的,以下就不给出了。

#include <iostream>
#include <cstring>
#include <cstdio>
#define MAXN 1000+10
using namespace std;
int N,V;
long long dp[1010][1010];//dp[i][j]取第i件物品时,背包容量为j时价值的最大值
struct node{
    int v;
    int w;
}a[1010];
long long dfs(int i,int j)
{
    long long ans;
    if(i<=0){
        if(j>=a[0].w)
            ans=a[0].v;
        else
            ans=0;
    }
    else if(dp[i][j]!=-1)
        ans=dp[i][j];
    else{
        if(j>=a[i].w)
            ans=max(dfs(i-1,j),dfs(i-1,j-a[i].w)+a[i].v);
        else
            ans=dfs(i-1,j);
    }
    dp[i][j]=ans;
    return dp[i][j];
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,-1,sizeof(dp));
        scanf("%d%d",&N,&V);
        for(int i=0;i<N;i++) scanf("%d",&a[i].v);
        for(int i=0;i<N;i++) scanf("%d",&a[i].w);
        
        printf("%I64d\n",dfs(N-1,V));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值