Arch 下配置Android编译环境


本人是个极度喜新厌旧的家伙,七八年了对ubuntu感到无比厌倦,最近将工作环境迁移到了ArchLinux,在配置Android编译三大件时,略走了些弯路,折腾了差不多一天,终于可以顺利开张了……


安装JDK:
sudo pacman -S jdk7-openjdk
Android 7换成jdk8,这里主要是包名与ubuntu不同,ubuntu使用的包名是openjdk-7-jdk、openjdk-8-jdk。

配置Python:
Arch已经安装好Python2.7和Python3,只是默认使用的Python3,而Android编译需要Python2.7,网上有一些工具可以指定Python版本,实际上不用那么复杂,因为python本身是一个符号连接指向
python3,自己手工链接到python2.7即可。
lrwxrwxrwx 1 root root 9 Dec 28 14:29 python -> python2.7*
lrwxrwxrwx 1 root root 16 Dec 30 19:34 python-config -> python2.7-config*

安装支持库:
这是比较费劲的一步,不能完全使用pacman命令完成,因为需要安装32位lib,因此首先要将/etc/pacman.conf中的32位选项打开:
[multilib]  
Include = /etc/pacman.d/mirrorlist  
之后执行一下pacman -Syy
这些库一般可以直接安装:
sudo pacman -S gcc git gnupg flex bison gperf sdl wxgtk squashfs-tools curl ncurses zlib schedtool perl-switch zip unzip libxslt python2-virtualenv bc gcc-multilib lib32-zlib lib32-ncurses lib32-readline
而ncurses5-compat-libs和 lib32-ncurses5-compat-libs两个库就没那么容易了,安装时一般会遇到key错误,而网上提供的PGP命令通常不起作用,这两个库只能自己下载源码编译,例如ncurses5-compat-libs:
cd ncurses5-compat-libs
makepkg -s -i
即可,同理安装lib32-ncurses5-compat-libs,git路径为:https://aur.archlinux.org/lib32-ncurses5-compat-libs.git
如果还有安装不上的库,可以在abs里翻翻,基本都能找到,然后考出来makepkg之……


Get!

参考:https://wiki.archlinux.org/index.php/Android#OS_bitness


展开阅读全文

没有更多推荐了,返回首页