题目
试题 算法提高 数组求和
资源限制
时间限制:1.0s 内存限制:256.0MB
问题描述
输入n个数,围成一圈,求连续m(m<n)个数的和最大为多少?
输入格式
输入的第一行包含两个整数n, m。第二行,共n个整数。
输出格式
输出1行,包含一个整数,连续m个数之和的最大值。
样例输入
10 3
9 10 1 5 9 3 2 6 7 4
样例输出
23
数据规模和约定
0<m<n<1000, -32768<=输入的每个数<=32767。
package 蓝桥练习;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
//max用于存储最大值
int max = -1;
//temp用于存放连续数字之和
int temp = 0;
Scanner s = new Scanner(System.in);
//n表示输入数字的个数
int n = s.nextInt();
//m表示连续数字之和
int m = s.nextInt();
int a[] = new int[n];
for(int i=0;i<a.length;i++) {
a[i] = s.nextInt();
}
for(int i=0;i<a.length;i++) {
//用于计算连续数字之和
for(int j = i; j<m+i; j++) {
if(j>=a.length) {
//循环成一个圈
temp = temp+a[j-a.length];
}else {
temp = temp + a[j];
}
}
//比较最大值
if(max < temp) {
max = temp;
}
//把临时的值置为0
temp = 0;
}
System.out.println(max);
s.close();
}
}