2019 PAT甲级秋季考试7-2 Merging Linked Lists (25 分)

Given two singly linked lists L​1​​=a​1​​→a​2​​→⋯→a​n−1​​→a​n​​ and L​2​​=b​1​​→b​2​​→⋯→b​m−1​​→b​m​​. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a​1​​→a​2​​→b​m​​→a​3​​→a​4​​→b​m−1​​⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L​1​​ and L​2​​, plus a positive N (≤10​5​​) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 10​5​​, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

题目很简单,保证长链一定比短链长2倍以上,直接开个新vector存就可以了 

#include<stdio.h>
#include<string.h>
#include<string>
#include<math.h>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
struct node
{
	int val,next;
}p[100500];
vector<int> v1,v2,v;
void dfs1(int x)
{
	if(x==-1)return;
	v1.push_back(x);
	dfs1(p[x].next);
}
void dfs2(int x)
{
	if(x==-1)return;
	v2.push_back(x);
	dfs2(p[x].next);
}
int main()
{
	int s1,s2,n,i,j,x,y,z;
	scanf("%d%d%d",&s1,&s2,&n);
	for(i=0;i<n;i++)
	{
		scanf("%d%d%d",&x,&y,&z);
		p[x].val=y;
		p[x].next=z;
	}
	dfs1(s1);
	dfs2(s2);
	
	//cout<<v1.size()<<" "<<v2.size()<<endl;
	if(v1.size()>v2.size())
	{
		int op=v2.size()-1;
		for(i=0;i<v1.size();i++)
		{
			v.push_back(v1[i]);
			if(i%2==1&&op>=0)
			v.push_back(v2[op--]);
		}
	}
	else
	{
		int op=v1.size()-1;
		for(i=0;i<v2.size();i++)
		{
			v.push_back(v2[i]);
			if(i%2==1&&op>=0)
			v.push_back(v1[op--]);
		}
	}
	for(i=0;i<v.size()-1;i++)
	printf("%05d %d %05d\n",v[i],p[v[i]].val,v[i+1]);
	printf("%05d %d -1\n",v[v.size()-1],p[v[v.size()-1]].val);
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值