PAT(甲级)2019年秋季考试 7-2 Merging Linked Lists (25 分)

Given two singly linked lists L 1 = a 1 → a 2 → ⋯ → a n − 1 → a n L_1=a_1→a_2→⋯→a_{n−1}→a_n L1=a1a2an1an and L 2 = b 1 → b 2 → ⋯ → b m − 1 → b m L_2=b_1→b_2→⋯→b_{m−1}→b_m L2=b1b2bm1bm. If n ≥ 2 m n≥2m n2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a 1 → a 2 → b m → a 3 → a 4 → b m − 1 ⋯ a_1→a_2→b_m→a_3→a_4→b_{m−1}⋯ a1a2bma3a4bm1. For example, given one list being 6 → 7 6→7 67 and the other one 1 → 2 → 3 → 4 → 5 1→2→3→4→5 12345, you must output 1 → 2 → 7 → 3 → 4 → 6 → 5 1→2→7→3→4→6→5 1273465.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L 1 L1 L1 and L 2 L2 L2, plus a positive N N N ( ≤ 105 ≤105 105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node Data is a positive integer no more than 1 0 5 10^5 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

题意

给出两个链表,从较短的那个链表的最后一个元素开始向前逐个插入第一个链表,要求每隔两个元素就插入一个,输出插入后的链表。

思路

先按照静态链表的方式读入这两个链表,然后遍历一遍,在遍历的时候存入vector,这时已经不需要知道每个元素的下一个的位置了,但是要存下这个元素当前的位置,然后把较小的那个vector翻转,在把他们按照题中的要求合并,这时再输出就很容易了。

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>

using namespace std;

struct node {
    int data, addr;
};

node nodes[100005];

int main() {
    int headA, headB, n;
    cin >> headA >> headB >> n;

    for (int i = 0; i < n; ++i) {
        int address, data, next;
        cin >> address >> data >> next;
        nodes[address] = {data, next};
    }

    vector<node> a, b, c;
    for (int p = headA; p != -1; p = nodes[p].addr)
        a.push_back({nodes[p].data, p});
    for (int p = headB; p != -1; p = nodes[p].addr)
        b.push_back({nodes[p].data, p});

    if (a.size() < b.size()) swap(a, b);
    reverse(b.begin(), b.end());
    for (int i = 0, j = 0, k = 0; i < a.size() || j < b.size(); ++k) {
        if (k % 3 == 2 && j < b.size()) c.push_back(b[j++]);
        else c.push_back(a[i++]);
    }

    for (int i = 0; i < c.size(); ++i) {
        printf("%05d %d ", c[i].addr, c[i].data);
        if (i == c.size() - 1) cout << "-1\n";
        else printf("%05d\n", c[i + 1].addr);
    }
}
  • 4
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值