L2-008. 最长对称子串
时间限制
100 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定"Is PAT&TAP symmetric?",最长对称子串为"s PAT&TAP s",于是你应该输出11。
输入格式:
输入在一行中给出长度不超过1000的非空字符串。
输出格式:
在一行中输出最长对称子串的长度。
输入样例:
Is PAT&TAP symmetric?
输出样例:
11
#include<stdio.h>
#include<string.h>
#include<string>
#include<math.h>
#include<set>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
char s[1005];
int i,j,len,maxvalue=-1,temp;
gets(s);
len=strlen(s);
for(i=0;i<len;i++)
{
temp=1;
for(j=1;j<len;j++)
{//奇数回文
if(i-j<0||i+j>=len||s[i-j]!=s[i+j])
break;
temp+=2;
}
if(temp>maxvalue)
maxvalue=temp;
temp=0;
for(j=1;j<len;j++)
{//偶数回文
if(i-j+1<0||i+j>=len||s[i-j+1]!=s[i+j])
break;
temp+=2;
}
if(temp>maxvalue)
maxvalue=temp;
}
printf("%d\n",maxvalue);
}