L1-023 输出GPLT

L1-023 输出GPLT (20 分)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

 

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<ctype.h>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
int main()
{
	int n,i,j,b,m[5],s=0;
	char a[10010];
	scanf("%s",a);
	b=strlen(a); 
	memset(m,0,sizeof m);
	for(i=0;i<b;i++)
	{
		if(toupper(a[i])=='G')//转化为大写 
		m[0]++,s++;
		else if(toupper(a[i])=='P')
		m[1]++,s++;
		else if(toupper(a[i])=='L')
		m[2]++,s++;
		else if(toupper(a[i])=='T')
		m[3]++,s++;		
	}
	while(s)
	{
		if(m[0])
		{
			printf("G");
			m[0]--;
			s--;
		}
		if(m[1])
		{
			printf("P");
			m[1]--;
			s--;
		}
		if(m[2])
		{
			printf("L");
			m[2]--;
			s--;
		}
		if(m[3])
		{
			printf("T");
			m[3]--;
			s--;
		}
	}
	printf("\n");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值