数据结构实验之链表六:有序链表的建立

Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;
第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Sample Input

6
33 6 22 9 44 5

Sample Output

5 6 9 22 33 44

Hint

不得使用数组!

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int a;
    struct node*next;
};
int main()
{
    int n,d;
    scanf("%d",&n);
    struct node*head,*p,*taile,*q;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    taile=head;
    int i;
    for(i=0; i<n; i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%d",&p->a);
        p->next=NULL;
        taile->next=p;
        taile=p;
    }
    while(n--)
    {//链表的排序其实和数组的排序差不多,都是一个与它的前一个或者后一个相比较,然后置换。
        //只需要换点的值就行了
        for(p=head->next; p->next!=NULL; p=p->next)
        {
            q=p->next;
            if(p->a > q->a)
            {
                d=p->a;
                p->a=q->a;
                q->a=d;
            }
        }
    }
   for(p=head->next;p!=NULL;p=p->next)
    {
        if(p->next==NULL)printf("%d\n",p->a);
        else printf("%d ",p->a);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值