Hdu 2116

Problem Description
As we all know, in the computer science, an integer A is in the range of 32-signed integer, which means the integer A is between -2^31 and (2^31)-1 (inclusive), and A is a 64-signed integer, which means A is between -2^63 and (2^63)-1(inclusive). Now we give the K-signed range, and two K-signed integers A and B, you should check whether the sum of A and B is beyond the range of K-signed integer or not.
 

Input
There will be many cases to calculate. In each case, there comes the integer K (2<=K<=64) first in a single line. Then following the line, there is another single line which has two K-signed integers A and B.
 

Output
For each case, you should estimate whether the sum is beyond the range. If exceeded, print “Yes”, otherwise “WaHaHa”.
 

Sample Input
  
  
32 100 100
 

Sample Output
  
  
WaHaHa


对于这题来说的话就是一道简单的数学题;

代码:

#include<stdio.h>
__int64  Pow(int n)
{
 __int64  s=1;
 int i;
 for(i=1;i<=n;i++)
    s*=2;
 return s;
}
int main()
{
 int n,f;
 __int64  t,a,b,min,max;
 while(scanf("%d",&n)!=EOF)
 {
  scanf("%I64d %I64d",&a,&b);
  max=Pow(n-1);
  min=-max;
  max--;
  if(n==64){
   f=0;
   if(a<0 && b<0){
    t=min-a;
    if(t>b)  f=1;
   }
   else if(a>0 && b>0){
    t=max-a;
    if(b>t)  f=1;
   }
   if(f) printf("Yes\n");
   else  printf("WaHaHa\n");
   continue;
  }
  if((a+b)>max || (a+b)<min)  printf("Yes\n");
  else printf("WaHaHa\n");
 }
 return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值