06-图2 Saving James Bond - Easy Version-------C语言

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

结尾无空行

Sample Output 1:

Yes

结尾无空行

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

        这题BFS算法和DFS算法均可,我采用的是DFS算法。

        这题的难点在于怎么表示这个图,我的第一想法是矩阵,但是N可能为100,那100阶的矩阵太大了,链表也不方便,因为要使用链表,得建立N个指向头结点的指针,而边也要储存两边,每个节点都有两个数据域,元素个数越多,使用链表越划不来。

        看了大佬的代码后,发现其实用不着储存图,我们判断这俩是不是接点的方法就是两个点之间的距离是不是小于等于D的,不需要再额外储存什么判断的数据。

//06-图2 Saving James Bond - Easy Version (25 分)
#include<stdio.h>
#include<cmath>
#include<stdlib.h>
#define Landradius 7.5

typedef struct{
    int x;
    int y;
} point;
int D, N;
point croco[101];
int visit[101];

bool Firstjump(int i);
bool Jump(int c1, int c2);
bool judge(int i);
int DFS(int v);

int main()
{
    int i=0, temp=0;
    scanf("%d%d", &N, &D);
    croco[0].x=0;
    croco[0].y=0;
    visit[0]=0;
    for(i=1;i<=N;i++){
        scanf("%d%d", &croco[i].x, &croco[i].y);
        visit[i]=0;
    }
    
    for(i=1;i<=N;i++){
        if(visit[i]==0 && Firstjump(i)){
            temp=DFS(i);
            if(temp) break;
        }
    }
    if(temp) printf("Yes");
    else printf("No");
    
    return 0;
}

bool Firstjump(int i)
{
    return sqrt(croco[i].x*croco[i].x + croco[i].y*croco[i].y)<=D+Landradius;
}

bool Jump(int c1, int c2)
{
    return sqrt((croco[c2].x-croco[c1].x)*(croco[c2].x-croco[c1].x) + (croco[c2].y-croco[c1].y)*(croco[c2].y-croco[c1].y))<=D;
}

bool judge(int i)
{
    return (abs(croco[i].x)>=50-D || abs(croco[i].y)>=50-D);
}

int DFS(int v)
{
    visit[v]=1;
    int temp=0;
    if(judge(v)) return 1;
    for(int i=1;i<=N;i++){
        if(visit[i]==0 && Jump(v,i)) {    //直接用距离来判断就可以了
            temp=DFS(i);
            if(temp) break;
        }
    }
    return temp;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值