hdu 1004 让气球飞 (map)

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

输出出现次数最多的字符串

//
//  main.cpp
//  160929
//
//  Created by 刘哲 on 17/4/13.
//  Copyright © 2016年 my_code. All rights reserved.
//
//#include <bits/stdc++.h>

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#define lowbit(x) (x&-x)
using namespace std;
#define ll long long
map<string,int>mp;
int n;
string s;
int main()
{
    while(cin>>n&&n){
        mp.clear();
        while(n--){
            cin>>s;
            mp[s]++;
        }
        int maxn = 0;
        string str;
        map<string,int>::iterator it;
        for(it = mp.begin();it!=mp.end();it++){
            if(it->second>maxn){
                maxn = it->second;
                str = it->first;
            }
        }
        cout<<str<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值