这是一道我们大一新生C语言课上我认为比较困难的题我想了很久才有一个思路,我认为很有必要记录下这道题。
Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
说明
再来一次比赛!看到气球飘来飘去真是太兴奋了。但告诉你一个秘密,评委们最喜欢的时间是猜最流行的问题。比赛结束后,他们会清点每种颜色的气球并找出结果。
今年,他们决定把这份可爱的工作留给你。
输入
输入包含多个测试用例。每个测试用例以一个数字N(0<N<=1000)开始,即分布的气球总数。接下来的N行每行包含一种颜色。气球的颜色是由多达15个小写字母组成的字符串。
N=0的测试用例终止输入,不处理此测试用例。
输出
每一个气球最流行的问题是每行的颜色。保证每个测试用例都有一个唯一的解决方案。
样本输入
5
green
red
blue
red
red
3
pink
orange
pink
0
样品输出
red
pink
题意
这道题主要是要我们输入几种颜色,然后找出颜色最多的一种。输入一个整数N代表N个气球,然后依次输入N个气球的颜色,最后输出一个最多气球的颜色。
主要思路
这题要用到有关字符数组的知识,我们依次输入颜色名称的字符串,首先我们定义两个数组,字符串a【】和整数数组b【】,和一个Max,我们依次输入颜色名称的字符串存入a【】,我们可以每次找出一个字符串然后在剩下的字串中找相同的并统计个数,如果这个次数最大,就把值赋给Max,最后输出最大次数的串。
代码如下
#include <stdio.h>
#include <string.h>
int main()
{
int n,i,j;
char a[300][200];
int b[1000]={0};
while (~scanf("%d", &n)&& n)
{
for (i = 0; i < n; i++)
{ scanf("%s", a[i]);}
int c = 0,max;
for (i = 0; i < n - 1; i++)
{
for (j = i + 1; j < n; j++)
{ if (strcmp(a[i], a[j]) == 0)
b[i]++;}
if (b[i] > c)
{
c = b[i];
max = i;
}
}
printf("%s\n", a[max]);
}
return 0;
}
注意点
我认为这道题需要注意每次循环之后要把b【】清零,否则系统会出错。
还有就是这道题关键要定义两个数组,一个记录最大次数,一个记录最大次数字符的位置。