hdu 5510 strstr/find/KMP

HDU-5510-Bazinga


Problem Description 
For n given strings S1,S2,⋯,Sn, labelled from 1 to n, you should find the largest i (1≤i≤n) such that there exists an integer j (1 ≤ j < i)and Sj is not a substring of Si.

A substring of a string Si is another string that occurs in Si. 
For example, “”ruiz” is a substring of “”ruizhang”“, and “”rzhang”“is not a substring of “”ruizhang”“.

Input 
The first line contains an integer t (1≤t≤50) which is the number of test cases. 
For each test case, the first line is the positive integer n (1≤n≤500) and in the following n lines list are the strings S1,S2,⋯,Sn. 
All strings are given in lower-case letters and strings are no longer than 2000 letters.

Output 
For each test case, output the largest label you get. If it does not exist, output −1.

Sample Input 


ab 
abc 
zabc 
abcd 
zabcd 

you 
lovinyou 
aboutlovinyou 
allaboutlovinyou 

de 
def 
abcd 
abcde 
abcdef 


ba 
ccc

Sample Output 
Case #1: 4 
Case #2: -1 
Case #3: 4 

Case #4: 3

题意:给N个串,求最大的i,使得存在j(<=0j<i),串j不是i的字串,有则输出i,否则暑促-1.

思路:先跑一遍循环,前后两个串进行比较,如果钱一个串是后一个串的字串,那钱一个串就没有用了。

eg:如果第i个串是第i+1个串的字串,如果第i+1个串是i+1后变的串的字串,那么第i个串久没有用了,如果第i+1个串不是后边串的字串,那么就找到了结果。

即定义指针i,j,如果s[i]是s[j]的字串,==>i++

else  ans = j;

(因为如果s[i]是s[j]的字串,那么i++,==> 1~i-1全部的串一定是i~j中某些串的字串,所以i~l-1就没有必要和后边的串进行比较了)//剪枝

如何判断s[j]是否是s[i]的字串?

1.KMP

2.s[i].find(s[j])!=string::npos

3.strstr(s[i],s[j])!=-1

其他解法:KMP+二分

//
//  main.cpp
//  160929
//
//  Created by 刘哲 on 17/5/30.
//  Copyright © 2016年 my_code. All rights reserved.
//#include <bits/stdc++.h>

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
typedef long long ll;
typedef long long LL;
using namespace std;

int n;
char s[505][2010];
int flag[505];
int main()
{
    int T;
    cin>>T;
    int n;
    int cas = 1;
    while(T--)
    {
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>s[i];
        memset(flag,1,sizeof(flag));
        int ans=-1;
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            if(flag[j])
            {
                if(strstr(s[j],s[i]))break;
                else
                {
                    flag[j]=0;
                    ans=max(ans,j);
                }
            }
        }
        cout<<"Case #"<<cas++<<": "<<ans<<endl;
    }
    return 0;
}

或者:

//
//  main.cpp
//  160929
//
//  Created by 刘哲 on 17/5/30.
//  Copyright © 2016年 my_code. All rights reserved.
//#include <bits/stdc++.h>

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
typedef long long ll;
typedef long long LL;
using namespace std;

int n;
//char s[505][2010];
string s[501];
int flag[505];
int main()
{
    int T;
    cin>>T;
    int n;
    int cas = 1;
    while(T--)
    {
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>s[i];
        memset(flag,1,sizeof(flag));
        int ans=-1;
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            if(flag[j])
            {
                //if(strstr(s[j],s[i]))
                if(s[j].find(s[i])!=string::npos)
                    break;
                else
                {
                    flag[j]=0;
                    ans=max(ans,j);
                }
            }
        }
        cout<<"Case #"<<cas++<<": "<<ans<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值