HDU 5510 Bazinga (KMP)

70 篇文章 0 订阅

Bazinga

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2979    Accepted Submission(s): 954


Problem Description
Ladies and gentlemen, please sit up straight.
Don't tilt your head. I'm serious.

For n given strings S1,S2,,Sn , labelled from 1 to n , you should find the largest i (1in) such that there exists an integer j (1j<i) and Sj is not a substring of Si .

A substring of a string Si is another string that occurs in Si . For example, ``ruiz" is a substring of ``ruizhang", and ``rzhang" is not a substring of ``ruizhang".
 

Input
The first line contains an integer t (1t50) which is the number of test cases.
For each test case, the first line is the positive integer n (1n500) and in the following n lines list are the strings S1,S2,,Sn .
All strings are given in lower-case letters and strings are no longer than 2000 letters.
 

Output
For each test case, output the largest label you get. If it does not exist, output 1 .
 

Sample Input
  
  
4 5 ab abc zabc abcd zabcd 4 you lovinyou aboutlovinyou allaboutlovinyou 5 de def abcd abcde abcdef 3 a ba ccc
 

Sample Output
  
  
Case #1: 4 Case #2: -1 Case #3: 4 Case #4: 3
 

Source

题意:给若干个字符串Sn,问符合Si不包含Sj子串且i>j的最大的i是多少。
思路:一开始想到字符串匹配,然后普通的s.find()会超时,所以想到用KMP。之后就是在匹配的时候的优化,一开始想到的是相邻字符串进行匹配,但是想错了,因为一开始想到的是只要找到相邻不匹配则代表最后也是这两个不匹配的会造成之后的不匹配,但其实不是确定的。所以听了zy1用的方法觉得很巧妙。首先相邻比较,若相同则继续,若不同则向上直到找到与之匹配的字符串,同时在向上的过程中更新最大值i。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
using namespace std;
int ne[10010];
char s[505][2005];

void kmp_pre(char x[],int m,int ne[]){
	int i,j;
	j=ne[0]=-1;
	i=0;
	while(i<m){
		while(j!=-1&&x[i]!=x[j])
			j=ne[j];
		ne[++i]=++j;
	}
} 

void preKMP(char x[],int m,int kmpne[]){
	int i,j;
	j=kmpne[0]=-1;
	i=0;
	while(i<m){
		while(j!=-1&&x[i]!=x[j])
			j=kmpne[j];
		if(x[++i]==x[++j])
			kmpne[i]=kmpne[j];
		else
			kmpne[i]=j;
	}
} 
 
int KMP_Count(char x[],int m,char y[],int n){
	int i,j;
	int ans=0;
	preKMP(x,m,ne);
	i=j=0;
	int flag=0;
	while(i<n){
		while(j!=-1&&y[i]!=x[j])
			j=ne[j];
		i++;
		j++;
		if(j>=m){
			flag=1;
			break;
			//j=ne[j];
		}
	}
	return flag;
}

int main(){
	
	int t;
	scanf("%d",&t);
	for(int cas=1;cas<=t;cas++){
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			scanf("%s",s[i]); 
		}
		int ans=-1;
		int l=1,r=1;
		while(l<=n){
			if(l==r)
				r++;
			if(r>n)
				break;
			if(KMP_Count(s[l],strlen(s[l]),s[r],strlen(s[r]))){
				l++;
			}
			else{
				ans=r++;
			}
		} 
		printf("Case #%d: %d\n",cas,ans);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值